So seems like my #Matrix homeserver hasnt been sending messages properly to other servers for days now.
Fuck this protocol, honestly.
Like I received other peoples messages, but nobody saw mine.
No errors, no nothing. I just thought I was getting ignored.
Solved by rebooting the VPS. Guess I'll do that every week now, then. What a fucking joke.